Incident Details

This page contains all current information on the status of this incident.



Start

2020-05-20 15:41:38 CDT


End

2020-05-20 16:54:27 CDT


Severity

Major Outage


Current Status

Resolved


Services Impacted

- CalTech Call Center


Impact Analysis

Call Center engineers are unable to receive phone calls.


Description

The CalTech Call Center is currently down with the following issues: 1. We are unable to receive inbound calls. 2. We are unable to receive direct calls to extensions. 3. We are able to make outbound calls.

We have a ticket open with an engineer working on the issue, and we will update this incident once resolved. Thank you for your patience! CalTech Team

***Update: Issue has been resolved and we are receiving calls again. Thank you again for your patience!



Timeline

2020-05-20 15:41:38 CDT